Typescript should follow semantic versioning

I guess this can be considered as a bug as it is breaking my apps.
If version 2.1.0 has breaking changes, why don’t set it to 3.0.0? Semantic versioning, right?
Typescript lives and has important … Read more


You do not need TypeScript or Flow

We all recognize that as javascript applications grow larger, implicit casting and a variety of type-related gotchas begin to make things difficult. In my experience, a line is crossed somewhere north of 25KSLOC. The question is what we do about it. Faceb...

Read more »